Ava-675: Golang vulnerability could cause denial of service to Aware

Release Date

7th of October 2022.

Overview

Vulnerabilities in Golang's encoding/gob and math/big packages could cause a denial of service to Aware.

Affected Products

  • Ava Aware:
    • All Stable upgrade channel versions before 5.2.4
    • All Beta upgrade channel versions before 5.2.0

Unaffected Products

  • Ava Aware:
    • All Stable upgrade channel versions after and including 5.2.4
    • All Beta upgrade channel versions after and including 5.2.0
  • Ava cameras: all versions
  • Ava Cloud: all versions

Resolution

This issue has been fixed in Ava Aware Beta upgrade channel version 5.2.0 and Stable upgrade channel version 5.2.4.

It is highly recommended that all installations running an affected version are upgraded to the latest release as soon as possible. Releases are available to download through the Ava Aware User Interface.

Vulnerability Information

Mitigations

There are no known mitigations for this issue.

Workarounds

There are no known workarounds for this issue.

Acknowledgements

Issue found by Ngolo-fuzzing and reported to the Go Team.

Disclosure Timeline

  • 01/08/2022 Issue found by Ngolo-fuzzing and reported to the Go Team.
  • 05/08/2022 Root cause established
  • 05/08/2022 Fix identified
  • 17/08/2022 Patched Ava Aware (Beta upgrade channel) released
  • 15/09/2022 Patched Ava Aware (Stable upgrade channel) released
  • 07/10/2022 Vulnerability publicly disclosed